ADR HTML

Version 1.1

Overview A quick blurb on what the program is about.

Quick Start A quick step by step to produce Web Pages.

Web Pages The heart of this product. Read this!!

Navigation Reading this will be very helpful.

File File Handling and Writing Web Pages (the guts)
Edit Data Base Handling.
Options Display Features.

_Find Seach and Find Records

Upgrade Convert Shareware to Registered Version

Merging Database Files

Registration Info. ~ Please look at this one.
Registration Form Another good one.




Green Arrows: The single arrows will move through the data one record at a time.
The double arrows will page through the data file four records at a
time.



HTML Title Line: This is the title line of an HTML document. This is the text you would
see in your Browser Bookmarks for the web page.



Header Frame Text: You can specify any appropriate text to place in the header frame of the
Column Frame Index.



HTML BODY TAG: This is the BODY TAG that conforms to the HTML standard. Whatever
is written for this body tag will be inserted directly into the HTML document produced.



The File Menu

The File Menu allows for creating, maintaining, and printing. It has the following options:

New Create a new database file.

Open Open a database file.

Save Save the current database file.

Save As Save the current database to a new file.
Write Html Active Record Write one Web page.

Write Html Frame Col. Style A column output frame style.
Write Html Frame Row Style A row output frame style.

Write Html Simple Style A very basic index style.

Import Insert records into the database.

Import Adr Book Import and Adr Book database file.
Export Export records to a file.

Upgrade Convert Shareware to Registered Version.

Exit Exit Adr_Html.



File New Menu

This selection will close the current database file and prepare for entering data into a new
database file.



Import Adr_Book

This allows merging a database file from the Adr_Book program also produced by Brown Bear
Software.



Write Html Active Record

This will write the currently selected record in Adr_Html (the one highlighted in turquoise) as a
Web Page.



File Open Menu

This selection will present the open file dialog box for selecting an exisiting database file to be
load.



File Save Menu

This selection will save changes made to the current database file. Saving the database file will
also save most of the configuration items associated with the database file.



File Save_As Menu

This selection will present the save file dialog to allow saving a current database to a new file.



Address Book Features

# Address File - C:ABBEARVADHTMLADEMO4 HDH
Fil= Edit Options Find Help

Adams, Scott

This section describes the features of the Graphical Interface Display for Html and Name List
Box.

The Address Book area permits navigation by using Tabs and Arrows. Clicking on the
Alphabetic Tabs will take you to the first record whose last name begins with that letter. If there
is no name starting with that letter no movement will be made. Clicking on the Green Arrows
moves sequentially foreward or backward through the records. The single arrow will move one
record while the Double Arrows will page through four records per time.

The Address Book area is also used to determine the active record. The active record is the one
highlighted in turquoise. To highlight the record of interest simply click on the name in the
Address Book. The active record will be the one used if you click on the Edit Button or select
Edit from from the pull down menu. The active record will also be the address copied into the
clipboard when selecting copy from pull down Edit menu. Double Clicking on the name
highlighted in Turquoise will cause the Edit dialog box to pop up for that record. The active
record will also be the record used when you choose the menu option Write HTML Active
Record...

The List Box is the fastest way to locate the person you are interested in. Typing the name in
the edit portion of the List will immediately highlight that person in the Address Book display.
The best way to do this is to click anywhere in the scrollable list area. This immediately causes
the name to be placed in the edit protion of the list box. At this point, you need simply to put
your fingers on the keyboard and begin typing the name of the person you are searching for. The
name will pop up in the address booklet as you type.

By using the scroll bars you can easily look at the names in your database. Clicking on a name in
the scroll area will make it the Active record. Double Clicking on a name in the scroll area will
call up the dialog box for making modifications to the record.



Import

Importing and Exporting is the process of exchanging data between applications by way of text
files. For Adr_Html, importing also implies merging of records. If you import records into an
existing Adr_Html database file, you will be adding records to that database. These text files
are often referred to as ASCII files. These files contain separated text strings that correspond to
individual record fields. i.e. Last Name, First Name, Phone Number, etc. Most database
and spreadsheet programs are capable of producing ASCII files containing their record
information in separated fields.

When you installed Adr Html onto your System, you should have received a Microsoft Write
file. The file name is Adrhtml.wri and the icon name after installation was Tutor. Refer to this
document for a step by step example for importing and exporting.

Adr_Html Version 1.0 has an easy to use dialog box to specify the individual fields of your
file, their order, and what separates each field.

If you are attempting to import data into Adr Html and not exactly certain how to proceed I
would first suggest you read the Import / Export section of the document mentioned above. Next
I would simply do some testing by using Adr Html to Export some data and then Import this
data back into Adr Html. When you do this, use a text editor to actually view your generated
file. This will give you a good understanding of what needs to be accomplished when moving
the data in from some other application program. Good luck and have fun.

There is one Import limitation. This has to do with the maximum number of records that can be
imported at one time. This is somewhere around 500 records. If you have more than this
number to import, you should brake it up into separate files. After you import one block of
records you need to save the database file and then reopen it before you import the next block.
The reason for this stems from a stack overflow problem that will occur.



File Exit

Exit the Adr_Html program.



Edit_ Menu

The Edit Menu manages the database file through Adding, Deleting, and Editing.

Add Create a new record.
Delete  Delete a record.
Edit Modify a record.

Copy Copy to Clipboard



Copy to Clipboard

Selecting Copy will move a copy of the currently active Name and Address to the Clipboard.
This can then be used for inserting into your word processor etc.



Adding and Editing

Adding or Editing goes to a dialog that lets you do exactly what you would expect. The only
point of interest is a dialog button that says "Add / Next". If you have entered the dialog box for
Adding, "Add / Next" will cause the record to be added and present you with cleared fields to
allow entering of another record. If entered for Editing the "Add / Next" will bring up the next
sequential record for editing.



Delete

Selecting Delete will bring up a dialog box asking if you really want to delete this record. The
record to be deleted will be the one currently highlighted in turquoise.



Options Menu
This menu permits setting configuration items.

Display What will be displayed on the Address Book.
Mode (US/International) Address entry field.




Mode (USA/International)

USA mode allows for entry of State and Zip code in a fasion that is typical in the United States.
International mode gives four complete address lines for entering State, Zip and Country in any
appropriate fashion. For a better explaination simply select this option from the menu and read
the description provided.



Display

The dialog box presented allows choosing what information will be displayed on the graphical
address book. Because there is limited room on the display not all record elements can be
displayed.

By selecting the Note check box you will see a Note.. text string highlighted in red appear on the
graphical address book for any record containing note text. By clicking anywhere in this red
area a pop up list box will appear to display the text. Clicking anywhere will cause the list box to
disappear.



Find

The find command locates strings in record fields. You can select the individual fields to search.
For example you could specify to only search in the Home Address. You can specify the match
to be case sensitive. You can specify a match to occur if the string is contained anywhere in the
field, if the string is at the beginning of the field, at the end of the field or if the string exactly
matches the field.

For example if you entered the words "Christmas Card" in the notes field for some of your
records you could locate all of these records by simply searching for the string. You would be
presented with the list of records that contain the string. You could then print labels for only
those records.



Registering ADR_HTML Ver 1.1

First of all, if you find this program useful that gives me a big chunk of satisfaction. I have to
admit that your registration gives me another chunk :-) I would like to hear from you with any
suggestions you have, no matter how trivial. Feel free to write to my address below, send E-
mail to mikeg@alaska.net or call (907) 278-1231

If you have decided that you like ADR_HTML and would like to register, please send a check

for $23.00 in US funds plus $2.00 for shipping and handling. ($5.00 shipping and handling
for International orders.) Make payable to Brown Bear Software or to Michael Gardner. 1
make every effort to ship in 24 hours. Mail to:

Michael Gardner

1231 Redwood Ct.
Anchorage, AK 99508

Please send the registered version to:

Name:

Address:

Please ship copy(s) of Ad r_HtmI

Price $23 (20% discount on 5 copies, 30% discount 10 copies or more)
Shipping ($2 U.S. orders, $5 International Orders)

Total Price

Payment __ Check _____VISA _____ MasterCard

Credit Card Number Expiration Date

Name Printed on the Card

Where did you find Adr_Html

Any Suggestions:






Merging Database Files

By example let us say you have created three database files: file1.hdr, file2.hdr, and file3.hdr.
To merge these into a single database file you first need to open one of the files and read it into
Adr Html. Of course you know how to do this, and lets say you load file1.hdr. To merge
file2.hdr select Import from the File menu. When you get to the Import dialog box click
Open... From the Open Dialog Box click on the arrow down by the List Files of Type:. You will
see an option that says Database Files(*.HDR). Click on this. Now in the file list above you
will see your database files. For this example you would see file2.hdr. Opening this will then
merge file2.hdr with file1.hdr. Do the same operation again for file3.hdr and you will have a
single database file. Not so bad!



File Export
Exporting is the process of writing Adr_Html database fields into a text file so they can be used
by some other application program. I would like to refer you to the Import Topic since there is
more verbage on the actual process that takes place.

The entire database does not need to be exported. You can export only selected records. You
select the records by using the find command. You simply need to execute the find command
before exporting your records.

The Export command can be used very effectively to produce merge files for your word
processing program.



Upgrade Cost for a Registered Owner

As a registered owner of Adr_Html you are entitled to free upgrades for one year. You are able
to perform this Upgrade Procedure by yourself. At the end of the one year time period an
upgrade fee is required if you would like the latest release of the program. The upgrade fee is
$15 US . Purchasing an upgrade will once again entitle you to free upgrades for one full year.
The best way for me to get the latest registered copy to you is via Email. Contact me at
mikeg@alaska.net. If this is not an option for you, simply print the registration form and postal
mail it to me. For the price put $15 US. A $2 USA shipping and handling is required and $5
for international orders. I hope this meets with everyone's approval.




Upgrading a Shareware version of Adr_Html to a full registered version.

Version 1.0 of Adr_Html provides a means for registered users to get free upgrades for one year
after purchase. It has always been difficult to inform registered users of a new release and to
provide upgrades in a cost effective manner. The Upgrade feature of Adr_Html solves this
problem.

Note: This menu option can only be selected from a Registered verion of Adr_Html.

When you obtain a registered version of Adr_Html the date of your purchase is stamped into the
software. You can see the registration date of your copy by selecting About Adr_Html under
the Help Menu. You will see a date that appears something like: Day 165 of 1996. Also note
that the top line of the About Adr_Html Dialog box of a Registered version will say: Adr_Html
Version #.# (The #.# values will vary depending on the release version.)

The latest shareware version of Adr_Html can be found on the Internet, BBS's, Compuserve,
AOL, and CD-ROM distributions. The About Adr_Html dialog box of a shareware version is
slightly different from the registered. On the shareware the first line will say Shareware
Version #.# The next line will also give a date indicated by day and year. This is the release
date for the shareware version. If this date is no greater than one year from the date of your
registered version, you will be able to convert the shareware version to a fully functional
Registered version. For example, lets say your registered version has the date Day 165 of
1996. From the Internet you pull down the latest shareware version from my homepage
http://www.alaska.net/~mikeg. On this shareware version you see that the release date is Day
320 of 1996. Since this is less than one year from the time you purchased a registered version,
you will

be able to convert it to a fully functional Registered Version.

Here (at last you say) is how it is accomplished. Unpack the new shareware version on your hard
drive in the directory C:\ADHTML##. The executable file unpacked will be
ADRHTML.EXE. 1t is this executable file which must be modified to produce a registered
copy of Html.

To accomplish this, run your registered version of Adr_Html and from the File menu select
Upgrade You will be prented with a dialog box. Click on the Open button. The file open
dialog box will appear. Use this to locate C\ADHTML#HA\ADRHTML.EXE. Open the file.
The ADRHTML.EXE will be converted to a registered version. A dialog box should pop up
saying that the conversion is successful.

The last step to verify the conversion is to run the program C\ADHTML#H\ADRHTML.EXE.
Do this and select About Adr_Html under the Help Menu. You will notice that it no longer
says Shareware Version #.#. It now says Adr_Html Version #.#. Also the date will no
longer be Day 320 of 1996. It will now have your original registration date of Day 165 of
1996. This is now your new registered version to run.

If another shareware version is released on Day 65 of 1997 you could once again follow the



steps above to convert the program to a registered version. Note that your original registration
date is always carried forward. You can continue to upgrade new shareware releases for a
complete year after you obtain your registered version.

A newer version of Adr_Html will read the database file from a previous version. An older
version will not read the database file of a newer version. For this reason, you should make a
backup of your database file before you begin to use a new version of Adr_Html.



Adr_Html Ver 1.1

This is a shareware product produced by Brown Bear Software. - which is really just another
name for me, Michael Gardner.

There are several ways to register this program. One way is to click on Registration Form
which will bring up a form that you can print and postal mail to receive your registered version.

The second method is through Email. mikeg@alaska.net By this method I will Email you an
attached .zip file containing the registered version. To do this simply contact me by Email and
the necessary arrangements will be made. This method has several advantages. First, you will
get the latest version right away. Second, there is no shipping and handling fee, so the entire cost
to you is only $23 US. I particularly like this method because this way I can easily verify that
you have receive the software. (I always worry about the postal mail)

You can also register by calling (907) 278-1231. This number is in Alaska USA.

If you are a current owner of a registered version of Adr_Html, and need to purchase an upgrade
version please click on Upgrade Fee.

No matter which method of registration you choose, I work very hard to get the registered
version into your hands as quickly as possible.

Feel free to examine this product completely. If you find that you are using the product, please
do the RIGHT thing and Register.

As a registered user :
1. You will receive the latest version of Adr_Html.

2. The restriction of allowing only 25 records in the database file will be removed. The registered
version can hold 3000 records in a single database file.

3. You are entitled to free upgrades to the latest version for one full year. Upgrading shareware
explains how this is accomplished. You have the responsibility and ability to obtain the latest
shareware version and converting it to a registered version. In other words it is just too difficult
for me to notify everyone of new releases. The best way to be alerted to any new releases is to
moniter the Brown Bear Software home page at http://www.alaska.net/~mikeg/.

I could list other registration benefits like technical support, but the truth is that the best reason
for registration is you will feel better, I am quite sure I will feel better, and I am absolutely
positive, Alberta, my much better half, will feel better.

Contact me for any questions:
Internet Email:  mikeg@alaska.net

WWW:  http://www.alaska.net/~mikeg/
Phone: (907) 278-1231






Overview

Adr_Html converts database records into HTML documents that can then be viewed by a web
browser. These HTML records can help you communicate on the Net. Email addresses and
URLs in your database become clickable links when viewed as HTML documents with your
Browser. Database fields provided for an Email address and a URL for each record. In addition
to these fields, however, any Email address or URL entered in the Free format Notes field of the
record will be converted to a clickable link. Click on Quick Start to see how all of this happens.



Quick Start

This is a step by step description of how to get the Sample database records
into Web pages. Once you see this you will know what this program is about.

1. Execute the Adr_Html program. If you are running Adr_Html for the first time, the sample
database file DEMO.HDR will be loaded into the program. If this is not loaded you should be
able to locate the file by selecting OPEN from the FILE menu.

2. Select the "Write Html Frame Col Style...' from the File Menu.

3. A dialog box will appear. There are options here for modifying your html pages. All you want
to do is click on 'Write Files...".

4. In the File write dialog box you should see a directory named 'pages'. Go to this directory.
This just gives you a place to write the files, but you can put them any place you like.

5. Click OK. You will get a help dialog that says that you need to open the file
FRAMECOL.HTM with your browser. Click OK.

6. Now fire up Netscape 2.0 or greater.
7. From the File menu of Netscape select Open File....

8. Locate FRAMECOL.HTM which most likely will be found in c:\adhtml10\pages\
framecol.htm

9. Open this file and you will now have a good feel for this program.



Writing Html Documents

This is what this whole program is about. Converting records entered into the Microsoft
Windows program, Adr_Html to Web pages that you (or anyone else) can view with a web
browser.

Click on Quick Start if you want a step by step to see how it works RIGHT NOW! I would
advise doing this before anything else. Seeing is understanding.

What will be described here is a little theory on how to best set up your HTML documents and
how best to keep them maintained.

Version 1.0 of Adr_Html can produce three HTML index web pages to view your individual
records.

There There index methods selectable from the File menu are:

Write Frame Column Style...
Write Frame Row Style...

Write Simple Style...

You must have Netscape 2.0 or later to view the Frame styles, while any browser that supports
HTML Table Tags can access the Simple style. All three of these methods can produce individual
HTML records for your entries in Adr_Html. All three produce identical individual records. The
only real difference between them is the HTML index file produced to access the individual
HTML records.

When you select one of these HTML output styles, you will be asked if you want to write all of
the individual HTML records, or simply to produce the HTML index file. If you have already

written all of the individual records from a previous Style selection, you need only produce the

index file for another Style.

If you had 350 entries in your Adr_Html database file, producing individual HTML record
files can be time consuming on some systems. Therefore you might not want to reproduce all of
the individual records any more often than needed. If you add a new record to Adr Html you
do not need to produce all of the individual records again. All that you need to do is write a new
HTML record for this newly added record. This is done by selecting Html Active Record...
from the File menu. To be able to access this new record you need to reproduce the HTML
index record. This done by selecting one of the index methods from the File Menu, and then
selecting to only have the index HTML records produced.



Writing Frame Column Style

The Frame Column Style produces an Index HTML Netscape Frames document. You will need
Netscape 2.0 or later to view this index style.

You can customize the HTML Title Line, the Header Frame Text, and the HTML BODY TAG
used by the three frames. The Header Frame can optionally be produced by selecting the Do
Header Frame check box. You can choose to produce HTML documents for all of your
database records or to only produce the Index records.




Writing Frame Row Style

The Frame Row Style produces an Index HTML Netscape Frames document. You will need
Netscape 2.0 or later to view this index style.

You can customize the HTML Title Line, the Header Frame Text, and the HTML BODY TAG
used by the three frames. The Header Frame can optionally be produced by selecting the Do
Header Frame check box. You can choose to produce HTML documents for all of your
database records or to only produce the Index records.

You can specify fields to be displayed in the Index frame. The optional fields are email address
and phone numbers.



Writing Simple Style

This style does NOT use Netscape Frames and consequently can be used by any browser that
supports HTML Table Tags. This is supported in almost all browsers.

You can specify fields to be displayed in the index page. The possible fields are Email Address
and Phone numbers






